Troubleshooting: MaxMind IP Location DB Not Updating
Condition or Error
The query resulted in a warning, alert will not trigger. No MaxMind IP Location DB is currently available
Causes
The MaxMind IP database is not being updated regularly, or is missing.
Solutions
Check the following items:
Check the LogScale humio repository for MaxMind update entries; if there are errors or issues with loading the database, they will be listed here. To search for the information, use this query:
logscale/maxmind/i
Check that LogScale instance has access to the internet so that the MaxMind database can be updated.
Check the setting of the
AUTO_UPDATE_MAXMIND
variable; if set to false the MaxMind database will not be automatically updated.Check the automatic update setting as shown in MaxMind Configuration.
Try manually updating the database as shown in MaxMind Configuration.